Issue with the devDept.Eyeshot.x64.v2023.dll and 64 bit CopyModule.dll with .Net 8.0

Currently I am developing a Window Application project (.Net 8.0)  with devDept 2023. In here when I add devDept.Eyeshot.x64.v2023.dll and 64 bit CopyModule.dll in my project, I am not able to add component from toolbox like Label, textbox, etc. 
Visual Studio 2022 Version : 17.9.4



Date Votes
  • Hello Dhananjay, 

    Unfortunately, Eyeshot 2023 doesn't support .NET8. However, you can try Eyeshot 2024, which was released a few days ago.

  • Hello Marcello,

    I have tried to do the project for both .Net 6 and .Net Framework 4.7.2 too for Eyeshot 2023 as the devdept bin folder consists .dll file for those, but still I am getting issues. The .dll file that I have used are
    and added devDept.CustomControls.Win.dll from the sample codes.

    Now, when I am adding a component from toolbox, this error pops up. This cam when I tried to add a button

    For .Net6.0 Core
    Though this was avoided when I remove the CopyModule.dll but then when I try to save a dwg file, it asks for TD_SwigCore_23.11_14.dll file but if I try to add it, then it says that "The reference is invalid or unsupported".

    For .Net Framework 4.7.2,
    I didn't had to remove the CopyModule.dll, but this error came when I tried to write file 
    `Could not load file or assembly 'devDept.Eyeshot.x64.v2023, Version=2023.3.592.0, Culture=neutral, PublicKeyToken=c8a727666e3c0a09' or one of its dependencies. An attempt was made to load a program with an incorrect format.`

    In anyways, I am not able to run the program smoothly. It will be helpful, if you could tell me what are proper .dll that I have to add for my project or if possible, could be please provide a empty solution with the necessary .dll and package file.

  • No need to worry about CopyModule.dll. For .NET 6, ensure that you have installed at least the latest stable build of Eyeshot 2023, and be sure to use the NuGet packages as detailed at the end of this article:

    If you encounter any issues after this, please feel free to open a support ticket.

    We appreciate your cooperation and understanding.

  • Sorry for the late reply.
    Well, it is now working nicely. I was trying to add .dll file as reference directly instead of adding from the NuGet package, which was causing error with the compatibility. These time, I have only installed the NuGet package and did not added any .dll file. Now, the program is running smoothly without raising compatible issues.

    Thank you for your help and support.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post